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A Short Guide to Using Graph Master

Background

Orchard monitoring is an increasingly important activity in the
production of high quality fruit. Graph Master facilitates the use of
orchard monitoring data in the wide range of decisions which orchard
managers address. Use Graph Master to compare seasonal monitoring
information collected from multiple locations over a number of growing
seasons. Graph Master works with any type of data collected over a
number of periods each season such as fruit size monitoring data or
pheromone trapping results. Use HortVision’s Link Master programme
to enter data into the databases used by Graph Master.

Graph Master is based on the concept of “comparisons”, eg compare the
fruit sizing data for a variety in one block with similar data from another
block either within the same season or between seasons. Comparisons
can include showing information for individual blocks as well as
averaging information between years and/or between locations.

Limitation of Liability

HortVision Ltd has endeavored to ensure that this product is technically
sound. While all reasonable efforts have been made to ensure that this
product is error free and functions correctly, HortVision Ltd and its
employees accept no direct nor contingent liability for any errors or
malfunctions which might occur. Decision Support software is complex,
you need to exercise caution in using outputs.

Installing Graph Master Onto Your Computer

Graph Master will install itself onto your hard drive by following these
instructions. Graph Master requires up to 1.5Mb of free hard disk space
to install; however, if you have previously installed other Orchard Master
software from HortVision then the core system will already be installed
and you will need much less than 1.5Mb of free hard disk space.



To install Graph Master:

1. Insert disk one of Graph Master into your drive “A”. (Note, if your
floppy drive is referenced by a letter other than “A”, substitute that
letter for “A” in these instructions.)

2. Make sure the computer is ready, with the Windows desktop visible
on the screen.

3. From the Windows Program Manager menu bar, pull down the File
menu and click on the command Run.

4. In the Run dialog box that appears, type the following for the
command line...
A\SETUP
click on OK, and follow any further instructions that may be
displayed on screen.

That’s all there is to it. Graph Master will install itself onto your hard
disk.

Need Help?

Everything doesn’t always go according to plan... and that’s why
HortVision can be contacted for technical support at any time on Free
Phone/Fax 0800 226 555 or you can write to HortVision Ltd, PO Box
634, Cambridge, New Zealand.

Using Graph Master

Run Graph Master by double clicking the Graph Master icon found in the
Orchard Master group in Program Manager. You will see a title screen
displayed while Graph Master loads.

Once Graph Master has loaded you will see a window labeled
“Comparison 1”. It is within this comparison window that you will
define the information to show in your comparison, and in which you can
view the resulting graph and/or raw data.



Each comparison window contains a “notebook’ with three pages. These
pages, or tabs, are labeled:

e Design
e Data
e Graph

You can change the tab you are viewing by clicking on the label for the
tab at the bottom of the notebook.

The Design Tab

The Design Tab is where you define the comparison: Which type of data
to show, for which blocks, and which information to show as averages
and which to show as individual lines on the graph.

The following illustrates the Design Tab:
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The Data Selection Table

The main section of the design tab is the Data Selection Table. This
table has eight columns and a row for each location*season that you have
recorded data against.

The first two columns are used to mark the rows of data to be included in
the comparison, and any averages that are to be calculated. Selecting
lines of data to graph is accomplished using the check boxes in the
“Show” column. For each row (location*season) that you want to be
plotted on your comparison graph, click on the check box and a tick will
appear indicating the row is selected. To deselect a row just click on the
check box again and the tick mark 1s toggled off. In the example shown,
the data for the first three rows will be shown on the graph as the
associated check boxes are ticked.

To graph the average of a set of lines use the “Avg” column. Enter the
same symbol (eg a number or letter) in the “Avg” column for each of the
rows to be averaged together. Every line with the same symbol in the
“Avg” column will be pulled into the average. When you enter the first
symbol for the average, a dialogue box will appear where you can
provide a meaningful title for the average, which will be displayed in the
Averages Table at the bottom of this tab, and will be used in the graph
legend. You can define further average lines to be calculated by entering
different symbols in the “Avg” column. If a particular row is to be of
more than one average, separate the symbols by a comma. For example
“1,2” entered in the Avg column puts that row in the average set with
symbol “1”” and also in the average set with symbol “2”. In the example
above, the data for the three Braeburn blocks are averaged together, and
the data for the three Fuji blocks form a second average.

To make it easier to find the rows you want to include in your
comparison, use the remaining six columns in the table to subset the data
so that rows to be displayed can be selected more easily. Each of the
columns has a heading and a drop-down list of items for that heading.
For example, the Variety drop-down holds a list of all varieties for which
you have recorded data. Select the special type “All” to not subset the
database based on that column. For example, clicking on the Variety list
and selecting “Braeburn” will limit the rows to showing only
locations*seasons for which you have recorded information against
Braeburn. Alternatively, clicking on “All” will show all varieties, not



just Braeburn. In the example above, the Orchard column has been
subset so that only locations*seasons are shown for Orchard 2 which was
selected using the drop down list box.

The rows are ordered according to the information within each column
left to right. Below the heading of each data column is a gray bar
containing the symbol “<==>%. You can click on this symbol and hold
the mouse button down while dragging to change the order of the
columns, and therefore change the order or rows within the table.

Note that the subsetting and changing of order of columns only affects
the way the data is displayed. The data in the database remain
unchanged. Use Link Master if you need to change the data.

The Average Table

Below the Data Selection Table is a smaller table that contains two
columns. This is used to name any averages you may have defined. The
table contains a reference to the symbol representing the average set, and
a description name for the average set. See the previous section for more
information on defining averages of your data

Load, Save As, and Close Buttons

At the bottom right of the Design Tab are three buttons used to load and
save comparisons, and to close the current Comparison window. The
close button does not exit the program, it simply closes the current
window, making another window current if there is another one open.

A comparison can be saved for viewing at a later date. The “Save As”
button effectively takes a snapshot of the Design Tab and remembers the
column subset choices, which lines are selected with a tick in the “Show’
column, and the definitions of any averages specified.

bl

To save a comparison, click on the Save As button. A dialogue will
appear asking for a name for the comparison, and listing existing
comparisons. Enter a name for the comparison, and select OK. If you
enter the name of an existing comparison, a message will appear
requesting you to enter a new name. Old comparisons can be deleted or
renamed using the “Manage Comparisons” item which can be accessed



from the menu at the top of the screen by selecting “Comparison”. Use
the “Load” button to select a previously saved comparison description.

The Data Tab

To change to the Data Tab, click on the tab marked ‘Data’ at the bottom
of the Comparison window.

The Data Tab lists the data for each of the locations*seasons selected in
the Design Tab. The data is retrieved directly from the database, and is
displayed in read-only format. This means that you cannot edit any data.
If you need to edit the data use Link Master. At the top of the tab is a
text area describing what data is being displayed. This information
comes directly from the heading drop down list boxes on the Design Tab.

The Graph Tab

To change to the Graph Tab, click on the tab marked ‘Graph’ at the
bottom of the Comparison window. The graph tab - which is the object
of this whole exercise! - is shown below:
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The Graph Tab consists of three sections, the graph, the legend table, and
the normalise box.

The Graph

The graph is where all selected data and average lines are displayed. The
graph is a line graph and for each date measurements have been made the
line 1s marked with a symbol. A list of symbols and their corresponding
number is listed to the right of the graph.

The Legend Table

The legend table is located below the graph. This table displays the
number corresponding to a symbol on the graph, and a description of
what that line 1s. The table can be scrolled using the scroll bar on the
right to see further lines in the legend. Both average and individual line
descriptions are shown in the table.

The Normalise Box

The Normalise Box allows the data to be displayed in three different
ways. Click on the appropriate radio button to select the type of graph to
display.

The “Default” option graphs the data against its day and month lining up
calendar date irrespective of year. This allows data from different
seasons to be overlaid and compared by calendar date.

The Reference Date option (Ref. Date) displays data as the number of
days from a fixed reference date. When you select the “Ref. Date” radio
button a dialogue box will appear in which you can fill in the date to use
as Day 0. You can supply the reference date with or without year. For
example, entering “1/10” for the reference date causes data to be plotted
as Days After October 1, regardless of year. This allows different
seasons data to be overlaid. Alternatively you could enter “1/10/93”
which will cause the data to be plotted as days from 1st of October, 1993
which will space subsequent seasons data out along the bottom axis.



The third option, “Days After Full Bloom” (DAFB) allows data to be
graphed against the number of days after Full Bloom Date. This differs
from the previously described Reference Date graph as the date used as
Day 0 in this case differs for each location*season. Note that data from
locations*seasons for which you have not recorded Full Bloom Date
cannot be plotted, but if selected for graphing are simply listed in a
message box to inform you that they have not been plotted. See the
Maintenance section for instructions on entering Full Bloom Dates.

The Menu

Across the top of the screen is the menu system. Click on the main
headings of the menu to open the submenus or to initiate an action.

Comparison Menu Item

Clicking on the Comparison menu item opens a submenu with the items
“New”, “Open”, “Manage”, and “Exit”.

The “New” item opens a new comparison window. The number of
comparison windows that you have open at one time is limited only by
the amount of memory in your computer.

The “Open” item is equivalent to selecting “New” and then clicking the
“Load” button in the comparison window. “Open” creates a new
comparison window and then loads the selected previously saved
comparison into it.

The “Manage” item allows you to manage the comparisons that you have
previously saved. You can delete and rename comparisons by selecting
this item. Use the select list to select the name of the comparison you
wish to rename or delete, and then press either the delete or rename
button.

The “Exit” item is the way to exit the programme. Select exit to quit out
of Graph Master.



10

Maintenance Menu Item

Click on the “Maintenance” item to open a submenu for entering
information about the types of measurements you are making, and to
enter Full Bloom Dates for individual locations*seasons.

The “Full Bloom Dates” item opens a dialogue that lists all
seasons*locations in a table for which you have recorded measurement
data. The column at the right side of the table is used to record the Full
Bloom Dates for individual seasons*locations. Enter as dd/mm/yy, ie
12/10/95 for 12 October, 1995.

The “Measurement Types” item opens a dialogue in which you can
define a new measurement. Provide a short label which will be used to
identify the measurement type in the Design Tab, and a longer
descriptive title which is used to label the graph. For each measurement
type you will need to use the radio buttons to define if this is a
measurement made more than once per year (such as fruit diameters
measured at intervals across the growing season) or only once per year
(such as total yield from a block). Note that this feature is for
compatibility with planned extensions to the Orchard Master software,
and that Graph Master is designed to work only with measurements made
at a number of times during the growing season. Finally, you will need
to define when the season begins and ends for the measurement being
defined. For example the season for fruit sizing will begin/end some
time in mid-late winter, while the season for an item such as chill unit
accumulation will begin/end some time in mid-summer. This definition
is needed to resolve certain conflicts which can arise when trying to
overlay data between different seasons.

Print Menu Item

Clicking on the “Print” item brings up a submenu containing the items
“Print Graph”, “Print Data”, and “Write Data to File”. Print Graph will
print the graph for the current comparison window, while Print Data
prints the data selected via the Design Tab for the current comparison
window. Printed output is directed to the currently selected Windows
printer. To change the printer or the setup of the printer, use the
Windows Control Panel as per instructions in your Windows manual.
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The Menu item Write Data to File enables you to create a file and save
the data selected via te Design Tab for the current comparison window.

Window Menu Item

The “Window” menu item is a standard Windows™ item used for
organising the comparison windows that you have opened. If you have
opened multiple comparison windows, they can be tiled (arranged side-
by-side) or cascaded (arranged in an overlapping fashion). The icons for
any comparison windows that are minimised can be arranged neatly at
the bottom of your screen using the “Arrange Icons” item in the
“Window” menu.

Help Menu Item
Clicking on the “Help” menu item will open the Windows Help System

and load the Graph Master help file. The Graph Master help file contains
substantially the same information as this guide.
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